Panne commande numerique sur radiateur Thermor Equateur

Demande d'aide pour dépanner un radiateur électrique. Recherche de documentation, de notice... Aide pour le réglage et l’utilisation des appareils de chauffage électrique.

de bwoufy

Bonjour,

j'ouvre un nouveau post pour tenter s'essayer de réparer un ancien raidateur de marque Thermor modele Equateur avec thermostat à commande digitale.
J'ai trouvé un ecran digital mais le cout du boitier est au minimum 200€. Mieux vaut changer de radiateur à ce prix là :(

Panne identifiée:

j'ai une panne visible avec l'écran digitale pour piloter le radiateur. Sinon il chauffe bien.
Le type de pannes observées sont les suivantes:
Branchement du radiateur + allumage --> l'écran s'affiche correctement, je peux me balader dans les paramètres mais au bout de plusieurs minutes, l'écran est figé. (seul le bouton power fonctionne)
et au redémarrage du radiateur, j'ai un écran allumé mais rien d'écrit dessus !
Si je le débranche physiquement puis le rebranche, l'écran revient à la normal

En parcourant le forum, je n'ai pas trouvé d'info sur ce type de radiateur

Afficheur en panne

Modification faites:
j'ai pensé à la panne du MKP X2, du coup j'ai changé avec les 2 composants mais maintenant, dès que je l'allume, j'ai un ecran blanc tout le temps :(

Carte de commande

analyse/modification/questions:
- j'ai remarqué que le condensateur X2 était un 0,68uf MKT X2, mais je ne dispose que de MKP 0,68Uf X2 --> il y t-il une différence entre ces 2 composants ?
- une trace noir était présente sur les 2 MKT initiaux. Mais avec le doigt, j'ai pu effacer ce dépôt ! Est-ce que cela peut être lié à la gros résistance qui est à coté ? Quel est son utilité ?
- malheureusement, je ne dispose pas d'un autre radiateur avec un boitier de contrôle pour m'assurer que celui-ci est bien fonctionnel

Carte électronique

Savez quels sont les composants/mesure à effectuer pour identifier la cause de la panne et savoir si cela peut être réparable?
(Je dispose que d'un multimètre mais si cela n'est pas assez, je suis prêt à acheter un testeur ESR...)

Merci d'avance pour votre précieuse aide ;)



03 Fév 2022, 17:18
 

de Cronos

Bonsoir.
Un plantage du microcontrôleur qui gère l'afficheur ? Je regarderais sur la carte afficheur s'il y a un condensateur de filtrage et le remplacerais... En fait, remplacer tous les chimiques que vous trouvez.

Les condensateurs MKT conservent leurs caractéristiques jusqu'à 1 GHz contre 100KHz pour les MKP. Ce qui n'aura pas vraiment d'influence sur le circuit d'alimentation du thermostat. Les 2 sont des condensateurs polyester autocicatrisants car à diélectriques solides qui en cas de dépassement de la tension de service maximale du diélectrique ne se mettent en court-circuit après un claquage. Ils perdent juste un peu de leur valeur, ce qui explique qu'au fil du temps et des claquages, la tension d'alimentation baisse jusqu'à ne plus assurer une fonctionnement correct des cartes électroniques.



03 Fév 2022, 20:57
 

de bwoufy

Bonsoir Cronos,

Merci pour ce retour et cette réactivité ;)

Coté partie commande, voici la carte electronique:

La carte de l'écran LCD du thermostat

Le composant cylindrique gris est un condensateur ?

et du coup vous me conseillez de changer aussi le condensateur bleu/noir sur la carte du thermostat? (si je ne me trompe pas, il n'y en a pas d'autre sur cette carte)

Sinon j'ai remarqué des taches sur les soudures de l'écran lcd:

Détail de la carte de l'écran LCD du thermostat

Est-ce qu'il est conseillé de les refaire ? bien qu'il semble soudé des 2 cotés du circuit ! ?



04 Fév 2022, 00:22
 

de Cronos

Bonjour.

Il reste de la résine qui n'a pas été nettoyée sur les soudures du connecteur de l'afficheur. La résine ne gène pas, mais les soudures ont une forme un peu douteuse. Ce qui s'explique par la difficulté à souder des gros connecteurs sur les pastilles très fines du circuit imprimé. Prudence si vous décidez de les refaire. Commencer par chauffer le connecteur en ajoutant de l'étain frais max 3 secondes et descendre rapidement sur la piste une fois que l'étain à fondu.

Je crois davantage au vieillissement du condensateur cms Panasonic 1500 C FK. Attention à ne pas arracher les pistes en le retirant !



04 Fév 2022, 12:35
 

de bwoufy

Bonjour,
j'ai reçu le cms Panasonic 1500 C FK ce weekend. Changement effectué hier soir et voici le résultat !

Afficheur dépanné

Je vais tout remonter ce soir et l'allumer plusieurs heures pour voir si tout ce passe bien.

De nouveau un grand Merci pour votre aide. Mon radiateur est de nouveau opérationnel !

NB: En effet, pas simple à dé-souder comme composant... :? J'ai un bout de la piste (seulement sur 1 coté) qui c'est légèrement décollée mais pas coupée. Mais bon le nouveau condensateur semble tenir. :D



15 Fév 2022, 14:21
 

de bwoufy

Bonjour,
au final j'ai toujours une panne. Dès lors que j'éteins l'écran lcd (appui long sur le bouton power), si je le rallume alors l'écran ne se ré-affiche plus. Je dois attendre plusieurs minutes ( 30min 45 min environ) avant que l'affichage revienne normalement (un appui sur n'importe quel touche fait apparaitre le rétro-éclairage). C'est comme si il fallait un moment pour qu'un condensateur se charge non ?

Je n'ai pas changé le condensateur bleu/noir sur la carte de puissance. Pensez vous que cela pourrait venir de celui-ci ?

Je suis preneur de vos avis :)



28 Mar 2022, 10:57
 

de Merik

non, je dirais : pas le temps pour un condensateur de se charger, mais le temps pour un composant à moitié défectueux de refroidir et retrouver des caractérisâtes correctes pour initialiser la carte logique.
Le problème apparaît-il si lorsque l'appareil a été éteint disons 24 heures, il est allumé puis éteint au bout de quelques secondes , puis rallumé ?



29 Mar 2022, 00:50
 

de bwoufy

Bonjour Merik,
Le probleme est là quelque soit la durée de coupure.
Que je coupe 10s ou 1journée, j ai le meme probleme. :?

Faut-il que je mesure la tension au borne du condensateur?



29 Mar 2022, 23:05
 

de Merik

Oui vous pouvez commencer par changer les condensateurs car ce sont les composants qui vieillissent les plus vite, et ne donnent pas des pannes franches.
Le condensateur chimique 1000 uF 16 volts et les deux condensateurs rectangulaires bleus sont à remplacer.

La panne n'est plus la même depuis que vous avez remplacer le condensateur qui filtre l'alimentation de l'afficheur ?

Il n'est pas fréquent de voir une panne qui disparaît au bout d'un délai car en principe les caractéristiques des composants se dégradent en chauffant, et les pannes apparaissent au bout de quelques temps.

Le délai n'est pas lié à la charge d'un condensateur car ceux-ci se chargent en quelques millièmes de seconde.



30 Mar 2022, 13:05
 

de apages

Bonjour,

Je me permet de "deterrer" ce post, car je rencontre quasi le même problème sur le même type de radiateur.

Pour moi la panne est plus franche car le thermostat ne s'allume pas. Le retro éclairage fonctionne et comme bwoufy, le bouton on/off fonctionne.

J'ai essayer d'éteindre le thermostat par le bouton et de le rallumer plus tard, de couper le courant au disjoncteur puis de le rallumer plusieurs minutes plus tard, mais toujours le même soucis.

Comme j'ai plusieurs radiateur identique, j'ai inversé les deux thermostats et le radiateur avec le nouveau thermostat fonctionne bien. Le problème semble donc être coté thermostat.

Par contre ma carte semble être un peu différente, car je n'ai pas le condensateur 1500 C FK

radiateur (2).jpg
radiateur (2).jpg (1.39 Mio) Vu 1618 fois


@bwoufy, finalement as-tu réussi a corriger ton problème et si oui comment?

Quelqu'un aurait-il une idée ?

Merci a tous



13 Jan 2023, 19:54
 

de LUDO

Bonsoir,
Le super condensateur pour l'horloge en cas de coupure du réseau n'est pas installé sur votre carte électronique logique mais c'est l'autre carte, la carte de puissance qui est probablement en cause. La partie alimentation de la carte de puissance est souvent défaillante comme indiqué dans les premiers commentaires.



13 Jan 2023, 20:17
 

de apages

Bonjour,

Etrange, car quand j'inverse le thermostat d'un radiateur qui marche vers le radiateur qui a un probleme d'affichage, tout est ok.

Les fonctions du thermostat sont affichée, je peux les modifier et le radiateur se met a chauffer.

J'aurais donc misé sur la carte thermostat et non sur la carte de puissance

Cordialement



13 Jan 2023, 20:53
 

de LUDO

Vous avez raison de penser que la panne est sur la carte logique si seulement celle-ci a été swappée.
Le clavier a aussi été remplacé pour éliminer un doute sur les touches ?



13 Jan 2023, 21:12
 

de apages

Rebonjour,

Je viens de tester la tension qui arrive sur le thermostat (3 fils : 1 rouge, 1 noir et 1 blanc). Au borne du rouge/noir j'ai entre 5.5v sur un et 5.7v sur l'autre donc a priori pas de problème d'alimentation (d'ailleur ce qui est etrange, la tension est négative ou inversée). le rouge a l'air d'etre la masse

Je testerais demain si l'alimentation au borne du PIC18LF2520 est correct ou pas

Cordialement



13 Jan 2023, 21:14
 

de apages

Rebonjour Ludo.

Non je n'ai pas inversé le clavier (cela n'a pas l'air si simple que ca). La raison est que quand je laisse appuyer longtemps sur power, le retroeclairage s'eteint (ce qui laisse penser que le thermostat est eteint car quand j'appuie sur les autre touche il ne se rallume pas), puis quand je laisse appuyer a nouveau quelques seconde sur power, le thermostat se rallume (retro-eclairage).

Puis apres quelques secondes, le retro eclairage s'eteint et se rallume dès lors que j'appuie sur n'importe quel touche du thermostat.

c'est comme si c'etait l'ecran qui avait un problème puisque le fait d'eteindre l'ecran pourrait mettre hors cause le PIC

Je vais essayé de regarder si je trouve une ref sur l'afficheur pour comprendre qu'elle pin est utilisé pour l'affichage

Cordialement



13 Jan 2023, 21:18
 

de LUDO

Pour éliminer tous les doutes, il faudrait aussi mettre la carte logique supposée en panne sur l'autre radiateur .. J'imagine par exemple, une carte logique moins tolérante à un défaut de l'alimentation puisque souvent les tensions d'alimentation déclinent progressivement. Mais si vous avez mesuré la tension 5V et qu'elle est correcte :|



13 Jan 2023, 22:06
 

de apages

J'avais deja fait ce test et la carte logique ne marche pas. meme symptome



13 Jan 2023, 22:37
 


Retourner vers Pannes et réglages



Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités

CGU         Copyright